1

We are running SharePoint 2016, and up until now have had no problems with Business Data Catalogs. Now when I try to access a page that has a DBC webpart on it I get this error and the page won't load at all:

Server Error in '/' Application.

Parser Error Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: Index was outside the bounds of the array.

Source Error:

Line 1: <%@ Register TagPrefix="cc1" Namespace="Microsoft.SharePoint.WebControls" Assembly="Microsoft.SharePoint, Version=16.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" %><cc1:BdcDataSource runat="server" LobSystemInstanceName="ace_reporting" EntityNamespace="http://xxx/xxx" EntityName="BOR_WP1" EntityId="0" Enabled="True" ShowSampleData="False" SelectCommand="" InsertCommand="" UpdateCommand="" DeleteCommand=""></cc1:BdcDataSource>

Source File: /SitePages/Dashboards.aspx Line: 1

-------------------------------------------------------------------------------- Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.8.4261.0

I even tried to add a brand new BDC webpart to an existing page that has nothing on it, and when I click to insert the webpart I get this error:

"Index was outside the bounds of the array"

I reset the BDC service from Central Admin and no change. Like I said everything was working fine yesterday, any suggestions? Thanks.

2
0

I rebooted all the servers in the server farm and things started working after that

2
  • Rebooting is not considered a solution especially in a production environment, you should merge logs from the SP servers then trace the log to can identify the root cause of the issue check also How to merge logs and use ULS viewer – Mohamed El-Qassas MVP Jan 10 at 7:26
  • Well with the production site down I didn't have too many options, so I had to try what I could. There was very little help in the log files. – AndyB Jan 11 at 13:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.