2

I have enabled a Home Site, but the global navigation does not show up. Does anyone know how to get it working? After a Home Site was setup, I was expecting this navigation piece to be visible somewhere, but it's nowhere to be seen.

Steps performed

  • Enable Home site
  • Waited for 1 hour

PowerShell script used

connect-SPOService -url https://contoso-admin.sharepoint.com
set-spohomesite -HomeSiteUrl https://contoso.sharepoint.com 

Home site

More details

6
  • Is the site a Hub site or connected to another Hub site? Commented Jan 3, 2021 at 12:34
  • Hi Callum. No. This site is a hub site Commented Jan 4, 2021 at 2:26
  • I am also experiencing this problem. I expected to have the global navigation option available in the settings cog, having seen it in a Microsoft demonstration video.
    – LucyVery
    Commented Jan 5, 2021 at 12:35
  • Judning by the official documentation, the demo from Ignite 2020 some features that were never implemented. Official documentation does not mention anything about global navigation. Commented Jan 6, 2021 at 1:17
  • I am facing the same issue over weeks now. Could you find out anything about a solution for this problem? Have you contacted MS support about it?
    – PhilFancy
    Commented Mar 25, 2021 at 7:20

3 Answers 3

2

As far as I know, capabilities of home site include:

  1. Easily accessible from the SharePoint mobile app for Android and iOS
  2. Search for the site is scoped to all sites within the organization
  3. Automatically set up as an organization news site

Per my test there is also no "Global navigation settings" in my tenant(using targeted release), strangely I can't find any articles referred to this.

There may be some customization or new features that targeted release can not access, we suggest you raise a ticket from Microsoft.

0

If you go to Sharepoint admin area (not the sharepoint settings this is the administration centre for sharepoint) select settings and add your sharepoint URL in the Home Site area - poss few hours to update

0

I was facing the same problem. I am not sure which step allowed me to enable global navigation, but I will list the steps that I performed.

The first thing I noticed was that I was not listed as the site owner for the Communications Site. I was working with the default Communications Site that was created with my account. A Service Account was listed as Site Owner of the original site, which I could not replace. Please read through the rest of the instructions before following these steps. I followed the instructions to replace my home page:

  1. Go to the Active Sites page of the SharePoint Admin Center.
  2. Select the root site (https://yourcompany.sharepoint.com).
  3. Select 'Replace Site' in the navigation above.
  4. Enter the URL of the site you want to use (/sites/yoursite).
  5. Select Save.

This did not enable Global Navigation, but it did set me as the Site Owner. That was the part that I am not sure you will need to do. Please be aware that the steps above will replace your existing root site.

Next, I set my 'home site' in the SharePoint Admin Center settings:

  1. Go to the Settings page of the SharePoint Admin Center.
  2. Select Home Site.
  3. Paste the URL of the communication site that you want to become the home site (https://yourcompany.sharepoint.com).
  4. Select Save.

Once this was complete, the 'replace site' option changed to 'change home site' when I selected the communications site on the active sites page of the SharePoint admin center. After opening the communications site for editing, the Global Navigation option was available in the settings.

I would suggest trying to set your home page in the admin center settings first before replacing your root site! I only included those steps because they were the steps that I took. I was just starting to create our intranet and did not have anything on the existing root site. I made this change because of a Note that I found on a page about enabling the Global Navigation:

Site owner permissions (or higher) to the home site are required to enable global navigation.

That Note can be found here: https://docs.microsoft.com/en-us/viva/connections/sharepoint-app-bar

I hope this helps others to be able to enable Global Navigation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.