2

This has been a maddening problem for a few weeks now and I can't seem to find the cause. I have a flow that simply needs to get the items from a list and filter them based on a field. I've tried this two different ways (using an odata filter and using "Filter Array") but something like 1/4 times I submit a new item to the flow, the "Get Items" action doesn't return it.

Here's an example of the odata filter I used, which does indeed work and return the proper items 3/4 times, the rest of the time it seems to leave out the most recently added items: enter image description here

And here's what happens when it doesn't return the items (which I have verified DO exist): enter image description here

I've tried explicitly turning on pagination but that doesn't seem to make a difference. I also tried putting a pause in to make sure the items have been written to the list before I get them, but to no avail. I can't find the commonality between all the failures, they just happen randomly and in streaks (like several attempts will fail in a row before one succeeds). The ONLY thing that appears to work is simply deleting all the items from the list in question before getting them, which is a completely unacceptable solution for obvious reasons.

Is this a bug? Or am I missing some detail here? Should this be escalated to MS?

2
  • Could you add a [Compose] action immediately after [Get Steps] to see if the items actually are retuning from SharePoint? For the input to [Compose] action, you could select value from the Dynamic content from [Get Steps]. Is column UID a number type or string? What's the value of variable ID? I'm assuming items count is <5K, right? – Matiur Rahman Dec 31 '20 at 17:56
  • I've used a compose action to check the outputs of Get Steps and what happens is it returns a truncated list, missing the most recently added items. UID is a number. ID is just the list item ID from an associated list. And yes, the item count is under 1k at this point. – thanby Dec 31 '20 at 20:02
1

According to your description, the get steps stop working randomly and returns nothing without an error(from the screenshot). It may be better to open a service request about it.

And have you checked the composed ID value in the get items step? Maybe you can create a new flow to test the missing items with the query UID eq ID with an IF condition. We can see if the condition works properly or not in another flow.

1
  • The "Get Steps" action does return data, but it's truncated and doesn't include all items (noticeably it misses the most recently-added items). This is true regardless of having the odata filter set, it can be clear and when examining the outputs of the action we still get truncated results. I've verified the UID eq ID works and passes the correct value. – thanby Jan 1 at 15:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.