0

Today one of our SharePoint sites was deleted for a second time, the first deletion was done yesterday and both without warning. I checked the deleted items section of the O365 SharePoint Admin site and there it was and i restore it back and it started working again. Anyone got any suggestions as to why this happens? the site has been working for several Months.

Looking at audit logs on protection.office.com revealed that the site was deleted by AAD to SharePoint Sync which and nothing more

Date:
2020-12-22 10:54:43
IP address:
User:
AAD to SharePoint Sync
Activity:
The site has been deleted
Object:
https://sharepint.sharepoint.com/sites/***
Information:

1 Answer 1

0

Please run following PowerShell to check whether the site missing group associcat with it:

$tenant = "yourTenantName"
$sharePointAdminUrl = "https://$tenant-admin.sharepoint.com"
$spoUrl = "yourSiteUrl"

Connect-SPOService $sharePointAdminUrl

$site = Get-SPOSite $spoUrl
$site.Template
$site.GroupId
$site.Owner

If the GroupId was set to an empty GUID (00000000-0000-0000-0000-000000000000), which means SharePoint Online sites with an empty group id are currently being deleted from the timer job since they are not properly configured as a group.

To solve the issue, create a unified group and associate it with your site via appending this to your site collection URL:

/_layouts/creategroup.aspx?mode=connectgroup

Similar issue:

https://www.nubo.eu/Groupified-SharePoint-Online-site-being-deleted-without-a-properly-associated-group/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.