1

We have a list in our Sharepoint Online instance, and I'm trying to add an alert for another user. When I do so, I receive this error message:

The following users do not have e-mail addresses specified: -{Name of User} Alerts have been created successfully but these users will not receive notifications until a valid e-mail or mobile addresses have been provided.

I've confirmed through user profiles that the work e-mail address and "SIP Address" has been specified for the user in question and that the user has permissions to the list and parent site. (Creating an alert for myself also works as expected, and these are the two user profile fields that contain my email address)

Thanks very much!

0

One more thing to check: Please navigate to SharePoint admin center > More features > User profiles > Manage User Properties > Work Email > Edit, make sure you have the Replicable checked under Policy Settings.

enter image description here Reference: "You do not have an e-mail address" error when you create an alert in SharePoint Online.

2
  • Much appreciate your taking the time... The Replicable option is indeed set on the Work Email field. I'm thinking this issue is something specific to the user in question, as alerts for the same list are working just fine for other users. – northshorehiker Dec 23 '20 at 20:26
  • @northshorehiker That makes sense. Try removing the issued users from the site and then re-add them to the site and set the alert again. Or you can modify their permission on this site and see if it brings any differences. – Chelsea_MSFT Dec 25 '20 at 2:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.