0

How do I get the Since to Until section to work? I tried adding a 1 second and subtracting a 1 second but the error is the same. If I leave Until blank it'll run, but it is not getting the correction version.

I was attempting to follow this article : https://sharepains.com/2020/09/24/changes-sharepoint-items-power-automate/ enter image description here

1

I managed to get it work with addDays(outputs('Get_item')?['body/Created'],-1,'yyyy-MM-ddTHH:mm:ssK'). We need to identify the format in ISO8601 format. Or we can just use the version number.

It works also with utcNow()

Update for an example: enter image description here

enter image description here

2
  • I wasn't able to get the Until section to work, can you show me your example? – williswin Dec 17 '20 at 4:48
  • @williswin, I updated the reply, please check. – Jerry_MSFT Dec 17 '20 at 9:48
0

It doesn't make any sense.. I'm also getting the same error. The only time it's working is when I'm using [created] or [Modified], by first getting the properties of the item by using ** [Get file properties]** action, and then using those fields as input for Since and Until.

I thought we could add/substract hours or minutes to/from [created] like

addHours(outputs('Get_file_properties')?['body/Created'],-4)

and then use it as input. But that's also not working.

0

I was unable to do a few seconds (addSec did not work unless you were precise on when the last version was), addDays did work though. I found that the best way was to just subtract one version number. Example below:

sub(int(items('Apply_to_each_2')?['{VersionNumber}']),1)

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.