2

I created Sharepoint - List as a stock list. I have a button in the column that sends a request for an item and at the same time adds a reserved flag to the item.

Code here:

{
  "elmType": "button",
  "txtContent": "Odeslat Žádost",
  "customRowAction": {
    "action": "executeFlow",
    "actionParams": "{\"id\": \"7347b7be-696f-46c8-bae8-78c230a354b3\"}"
  },
  "style": {
    "background-color": "#03A9F4",
    "color": "white",
    "visibility": {
      "operator": "?",
      "operands": [
        {
          "operator": "==",
          "operands": [
            "[$Sloupec11]",
            ""
          ]
        },
        "visible",
        "hidden"
      ]
    }
  }
}

Screenshoot: enter image description here

So far, everything works, but when you search for an item using the search bar, the button stops working.

enter image description here

Is my procedure bad? Thank you for your help.

Best Regards

Frantisek

EDIT: OK, I understand there's a search error. For filtering, but the button works. Is there a way to create a search item using a filter?

Something like this: enter image description here

1
  • Sounds like you have an additional question not related to the executeFlow action no longer working. Please open a separate question for that, thanks! – theChrisKent Dec 9 '20 at 16:02
1

Your format is correct. I can confirm I'm having the same issue. The Launch Flow action works just fine until I search the list. This is a bug that should be submitted here: https://aka.ms/spdev-issues

All other row actions execute, but not executeFlow - the flow panel never shows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.