0

I have the following Rich Text field inside my site columns inside an online site collection:-

enter image description here

now when i add the above site column inside a document library >> the Rich Text facility will not be provided, and i will get a plain text field as follow:-

enter image description here

any advice on how i can add a Rich Text field inside a document library? Thanks

1 Answer 1

0

This is a known issue in SharePoint that Rich text or Enhanced rich text is disabled in document libraries by default, as well as the Edit Multi-Text option in Edit Form. See a UserVoice post here.

Currently we can only use the FORMAT TEXT panel using classic experience. HTML elements are acceptable in modern experience though.

--

In addition, if you do not see that panel when editing document properties in classic experience, open the document library using SharePoint Designer and edit the column via Lists and Libraries > select library > Edit list columns under "Customization" > select (Enhanced) Rich Text column > Column Settings (, as is described in this blog).

Uncheck “Enhanced Rich Text” and then check it again (the settings should all be selected by default). After that, save the changes in SharePoint Designer.

Now back to the Edit Form in the document library, you should be able to see the panel.

enter image description here

enter image description here

2
  • thanks for th workaround and info.. but it is recommended to do these changes?
    – John John
    Nov 19, 2020 at 13:28
  • @SharePointTestDev There is nothing to worry about. We don’t really change or add anything to the default settings, if you have noticed. We just help to activate the Rich Text feature by reconfigure it again using SharePoint Designer 2013. The checkboxes are checked by default when we create this Rich Text column, somehow it does not function in the first place. Nov 19, 2020 at 23:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.