0

Is it possible to have custom permissions within one document library? Say the document library has 4 folders:

  • Human Resources
  • Finance
  • Services
  • Facilities

I have also created 4 corresponding user groups (HR, Finance, Services, Facilities)

I'd like the Human Resources folder BE VISIBLE only to the users in the Human Resources group, Finance - only to Finance users, etc). The folder structure above is simplified, there are actually more folders and some of them are subfolder,etc. Otherwise, I'd just create 4 document libraries each with different permissions.

I tried to right click on the Human Resource folder and chose 'Manage Access' I give a direct access only to the owners (myself) and the Human Resource group of users. It's all good but when I try to access this folder as a HR user, I get the following notification. Is it possible to prevent it to appear each time an authorised user tries to access this folder. Or is it a wrong way of setting the permissions? Thanks

enter image description here

4
  • Can you confirm whether you have first stopped inheriting permission at the document library level as well as at the folder level? Here is how to stop inheritance here – Matiur Rahman Nov 15 '20 at 1:38
  • I have not done it at all. Shall I do it now at both levels? – Wasteland Nov 15 '20 at 9:04
  • Actually, I had done it at the folder level. – Wasteland Nov 15 '20 at 9:07
  • I've stopped inheriting permission at the document library level as well. Also, what's interesting if I navigate to the HR folder from the top level of the document library, it's doing fine (without any notice). If I use a link (basically a copy/paste from the browser url), then the obove notice appears. – Wasteland Nov 15 '20 at 9:15
1

The screenshot you provided looks like an external sharing link, but based on my testing, I cannot reproduce your problem.

If possible, please provide more information on setting permissions for these folders step by step.

How to Set Unique Permissions in SharePoint:

https://oit.unr.edu/services-and-support/data-storage/sharepoint/sharepoint-shared-documents/sharepoint-unique-permissions/

3
  • I think it might be something to do with my url. I'll try to come up with a way of generating the link for a group given access via direct access somehow. I'll report back. – Wasteland Nov 17 '20 at 19:39
  • Waiting for your feedback. – Julie_MSFT Nov 18 '20 at 0:55
  • The way I originally generated the link to that folder was incorrect (I copied it from the web browser address bar). Having done it properly (using the article you linked to) has worked fine. – Wasteland Nov 20 '20 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.