0

So I have converted SP2019 from NTLM to Azure AD auth, setup azureCP etc. To do this I extended the webapp from "servername:80" -default to "https://myurl.com" - intranet. The default zone "servername:80" has NTLM setup, and no azure ad. The intranet URL "https:myurl.com" has Azure AD setup with no NTLM. Search is crawling the default zone, and I have in a server name mapping. The issue is that the links in library / list alerts are pointing to the default URL "servername:80" and not the the intranet URL. URL links in workflows are correct.

3
  • Could you switch default URL with intranet URL? Alert triggered by search should apply the default URL.
    – Mark L
    Nov 10 '20 at 0:32
  • @Mark L If I switch the URLs the issue is resolved, but a new issue pops up. In the search results page when you hover over an item and click on "View In Library" it tries to take you to the wrong URL, it takes you to the crawled URL because i'm no longer crawling the default zone. Nov 10 '20 at 19:23
  • If so, update your company DNS to point myurl.com to same IP as servername. Then your company's computers will browse local ip when open myurl.com
    – Mark L
    Nov 10 '20 at 22:20
0

Have you added the intranet site url in content source?

Here is an article about extend web application with different authentication and configure search for your reference(please pay attention to the later part in this article):

https://sharepointobservations.wordpress.com/2013/08/06/sharepoint-2013-configuring-search-to-crawl-web-applications-using-claims-and-adfs-2-0/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.