0

When initially setting up Voice with Microsoft Teams, I ran into the following issue when trying to assign phone numbers to users. I would select the phone number, user and emergency location, but when selecting "apply", the following error message would appear.

"To continue accept the enhanced emergency disclaimer for the selected location"

However, there doesn't appear to be any way to accept the disclaimer.

To be clear, I understand the issue. There are going to be issues trying to dial 911 using the service-not that you won't get through, but you might be redirected to the wrong dispatch services for your location. That is all explained in Microsoft's documentation

Documentation for "Skype for Business" also seems to have a solution, but doing so requires the use of PowerShell, installing a module, and issueing a command

The problem I run into here, is that I can connect with the MicrosoftTeams module, but it doesn't accept the Set-CsOnlineEnhancedEmergencyServiceDisclaimer command which appears to be a SkypeforBusiness command, and I can't get that module to work. Besides, there has to be a better way to accept a disclaimer than copy/pasting into a cli that 95% of Windows Users don't actually know exists.

3 Answers 3

0

I ran into this same issue, and the only thing I found that worked to get past it was to go into the "Locations" section of Teams Admin, and add a new location with the same address, etc. When creating the location, you have the opportunity to check the box to accept the 911 disclaimer.

After that, I was able to assign phone numbers to users at that location.

0

Current Work Around:

The current interface is based on https://admin.teams.microsoft.com/dashboard. But in the menu on the left, the second-to-last option is the "Legacy Portal." This opens https://webdir2a.online.lync.com/LSCP. Here you can go through the same motions, only when you click 'apply' an actual disclaimer pops up that you can acknowledge and accept. Then you can go about adding/modifying phone numbers for users without issue.

1
  • Luis Ramos reports this option is no longer available
    – Kit
    Jan 9, 2021 at 14:56
0

Currently that option is no longer available since Microsoft removed the Legacy Portal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.