0

I've successfully used REST in a HTTP call in my SPD 2013 workflow to break permission inheritance and assign unique permissions to various groups. I have another workflow where I want to re-inherit permissions or change the permission level for the existing assigned group on an item that has unique perms but no matter what I do I cannot get it to work.

I build dictionary with Accept and content-type set to application/json;odata=verbose.

I then set a variable with my URL like so: [workflow context:current site url]_api/lists/getbytitle/('ListName')/items(ID)/resetroleinheritance

The request type is POST. Each time I run the workflow the permissions remain unique and nothing changes, I get a Bad Request response in the responsecode. What am I doing wrong?

I must mention that this is a document set, but I successfully broke inheritance via the same method, I now need to do the reverse if possible. Thanks.

UPDATE: I got this working to a degree now, it turns out I had not registered this workflow app on the app permissions page, must have got confused when I did it on a test site. Rather than have to re-inherit perms and remove all the groups I don't want is there a way to remove just one groups role from the item that already has unique perms?

0

Can you try changing the url to

[workflow context:current site url]_api/lists/getbytitle/('ListName')/items(ID)/ResetRoleInheritance()

2
  • Hi I have also tried that but again I get bad request. This is all inside an app step and my workflow has been granted app permissions. Other workflows which breakroleinheritance work fine on the site. So this has really confused me.
    – Tunni
    Sep 22 '20 at 19:48
  • Just a thought. Do I need to register every workflow that is managing permissions in the site app permissions page? Or once I’ve done it in one workflow will all the others work too? I have multiple workflows that need to do this. A different workflow broke the permission inheritance.
    – Tunni
    Sep 23 '20 at 5:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.