0

I had a two server SO2016 OnPremise farm, needed to add a second Web Front End and remove the old one. Once set up the third server, our system admin installed the August2020 CU on all machines, but on the Application server we got the following error:

MSI (s) (D4:E8) [07:51:15:343]: Product: Microsoft SharePoint Foundation 2016 Core - Update 'Security Update for Microsoft SharePoint Enterprise Server 2016 (KB4484473) 64-Bit Edition' could not be installed. Error code 1603. Additional information is available in the log file C:\Windows\TEMP\sts-x-none_MSPLOG.LOG.
MSI (s) (D4:E8) [07:51:15:343]: Windows Installer installed an update. Product Name: Microsoft SharePoint Foundation 2016 Core. Product Version: 16.0.4351.1000. Product Language: 0. Manufacturer: Microsoft Corporation. Update Name: Security Update for Microsoft SharePoint Enterprise Server 2016 (KB4484473) 64-Bit Edition. Installation success or error status: 1603.
MSI (s) (D4:E8) [07:51:15:343]: Note: 1: 1729
MSI (s) (D4:E8) [07:51:15:343]: Product: Microsoft SharePoint Foundation 2016 Core -- Configuration failed.
MSI (s) (D4:E8) [07:51:15:344]: Windows Installer reconfigured the product. Product Name: Microsoft SharePoint Foundation 2016 Core. Product Version: 16.0.4351.1000. Product Language: 0. Manufacturer: Microsoft Corporation. Reconfiguration success or error status: 1603.
MSI (s) (D4:E8) [07:51:15:347]: Attempting to delete file C:\Windows\Installer\2659b40.msp
MSI (s) (D4:E8) [07:51:15:348]: Unable to delete the file. LastError = 32
MSI (s) (D4:E8) [07:51:15:368]: Deferring clean up of packages/files, if any exist
MSI (s) (D4:E8) [07:51:15:368]: Attempting to delete file C:\Windows\Installer\2659b40.msp
MSI (s) (D4:E8) [07:51:15:439]: MainEngineThread is returning 1603
MSI (s) (D4:04) [07:51:15:442]: RESTART MANAGER: Session closed.
MSI (s) (D4:04) [07:51:15:442]: No System Restore sequence number for this installation.
MSI (s) (D4:04) [07:51:15:452]: User policy value 'DisableRollback' is 0
MSI (s) (D4:04) [07:51:15:452]: Machine policy value 'DisableRollback' is 0
MSI (s) (D4:04) [07:51:15:452]: Incrementing counter to disable shutdown. Counter after increment: 0
MSI (s) (D4:04) [07:51:15:452]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (D4:04) [07:51:15:452]: Note: 1: 1402 2: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Installer\Rollback\Scripts 3: 2
MSI (s) (D4:04) [07:51:15:453]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: -1
MSI (s) (D4:04) [07:51:15:455]: Destroying RemoteAPI object.
MSI (s) (D4:20) [07:51:15:455]: Custom Action Manager thread ending.
MSI (c) (90:C4) [07:51:15:458]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: -1
MSI (c) (90:C4) [07:51:15:459]: MainEngineThread is returning 1603

The day after the September 2020 CU has been relased, so I tried to install it on each server but the result is the same. On two servers I have been able to install the patch, on the other one it fails.

I tried to run the installer with different admin accounts, so I'm not sure if it is a permission issue or somethig else. I also found this and this discussion, however, did not help.

I would exclude a permission issue, because on the other two servers I used the same account and it worked.

2

1 Answer 1

0

I opened a Microsoft ticket, after almost a month trying everything, we have not been able to fix the problem. So I decided to set up a new server, add it to the farm using powershell, since the wizard does not allow to edit the farm as long the installed packages are not the same on each server.

The old one has been removed using powershell too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.