2

We currently have the effect that when clicking Open with explorer in a document library we can't add / edit / change items. The folder opens but as soon as we try to add something the explorer.exe freezes. Same goes for mapping a library to a drive letter.

By default we access our intranet via http. About a year ago we added the option to access it via https. And when accessing our Intranet via https everything works fine.

Anyone else has this feature/bug? Is there a way to fix it (a patch that might have been responsible)?

We use SharePoint 2013 on Windows Server 2012 R2. Client OS is Windows 10.

Edit1: Here are our AAM / IIS settings: enter image description here enter image description here

Edit2: We just got hold of a laptop without the latest patches and the behavior is the same. So our Patchday wasn't the issue here.

Edit3: We tried rewriting the URLs through our KEMP load balancer but the result is a 'broken' intranet due to the hard links.

Edit4: taking a look with fiddler revealed that as soon as I try to create a new folder this happens (the blurred URL is always 'intranet.company.com): enter image description here

The only 302 message I can think of is the error page we set in IIS. But this has been made ~2 months before we encountered this issue. enter image description here

Edit5: Trying to upload a file (credits.txt) takes some time and then presents me with these messages including a 504: enter image description here enter image description here

  • Have you set up AAM for you intranet sites? If you set up AAM, then you need to access via https. – Emily Du - MSFT Sep 8 at 10:11
  • Thanks for the comment but that does not fix this issue. Removing the https AAM entry (and its IIS binding) does not solve this issue. I updated the question with our AAM/IIS config. Also with these settings everything has been running fine for a year. – AM2FTW Sep 9 at 6:22
  • Is there a specific reason why you still have the option to access the application through HTTP? – Christoffer Sep 9 at 11:44
  • We still have lots of links within our Intranet (3000+ Site Collections) pointing directly to http ://intranet.company.com/*. Changing those manually would be 'challenging'. I also looked for PowerShell to help us here but couldn't come up with something (then again i am not super familiar with PS). – AM2FTW Sep 9 at 11:52
  • You could use URL rewrite to change all http:// requests to https://. Check this link – Sandro Sep 11 at 14:19
1
+150

The Fiddler screenshot (edit3) indicates that the request #76 returns with a 302 i.e. it is redirected to the root and then results in a 401 (not authorised)

Can you try to grant the user read access to the root site on your farm? and then re-test?

Can you also try to disable the custom error page? (and restart IIS) would be good if we can exclude this as a cause.

Paul

| improve this answer | |
  • Resetting the custom error page in IIS and the web.config did the trick. However I don't fully understand how it took so long for this behavior to show up(we set it almost 2 months ago) and why it threw a 404 message. Also all users have access to root site and that 404 page. THANK YOU for pointing us in the right direction! – AM2FTW Sep 14 at 6:59
1

I would fire up Fiddler and intercept the network traffic between the client and SharePoint. Can you establish a direct connection to one of the front-end servers by changing your local hosts file? This way you bypass the load balancer. Paul

| improve this answer | |
  • Thank you. The load balancer is currently not being used. However Fiddler revealed that when trying to create a folder it answers with many 401 / 302 messages. I updated my initial question. – AM2FTW Sep 10 at 9:36
  • 1
    Cool. Great news. – Paul Sep 14 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.