I have a problem on the following system:

A domain Sharepoint Foundation 2010 server named srv-sharepoint

Any client machine on the same domain.

When I try to connect to http://srv-sharepoint in IE I make a request and get a response (fiddler):

HTTP/1.1 401 Unauthorized
Server: Microsoft-IIS/7.5
SPRequestGuid: 350732e3-82e9-41ef-9c28-178eaaf504bb
WWW-Authenticate: Negotiate
WWW-Authenticate: NTLM
X-Powered-By: ASP.NET
Date: Fri, 03 Feb 2012 12:05:14 GMT
Content-Length: 0
Proxy-Support: Session-Based-Authentication

When I connect using firefox, under the Web Developer Console there are 2 Get requests that receive a 401 Unauthorized And a subsequent Get request that gets a 302 Redirect to Home.aspx that works

IE's behaviour is not consistent; there are times that sharepoint authentification works on IE. Most of MS products (word, excel, onenote, sharepoint workspace) are not working also when connecting to sharepoint items.

Looking at raw request the major difference between IE and Firefox is that firefox contains the Request Header Authorization

Thank you

2 Answers 2


I did not experience the problem after modifying the server hosts configuration and adding the server name to point to localhost.

Not pointing your SharePoint servers at themselves seems to be one of the most common mistakes according to Todd O. Klindt.


One question and one idea: Are you using 32 or 64-bit version of IE? When you see this error message in both bit versions and IE only, check setting DisableLoopBackRequest in registry from this link http://support.microsoft.com/kb/896861 (or steps from Method #1 first)

  • I am using IE 32. I will try to use x64 next time the problem occurs, and try the fix above. Thanks. Mar 28, 2012 at 7:58
  • I had the problem again today. I looked for a security audit failure in both client/server machines, but everything is ok. I'm confused on which machine I should make the registry changes ? My client machine or on the server machine ? Apr 3, 2012 at 11:28
  • On your machine. So probably there is another issue and someone else will help you, sorry
    – Molik
    Apr 4, 2012 at 14:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.