0

In my new SP Online Team site(private group), I have got Site Collection level App Catalog enabled in the site.

I am able to upload SPFx web part package to the App Catalog. But unlike my other SP online team sites, the Pop-up to deploy the app is not coming. Moreover the options for Apps in the app catalog ribbon Files Tab("View Details Page", "Manage Installed Apps", "Deploy") are also not there.

As per my testing, there is no problem in the app package as it is getting deployed in other site collection's app catalog and working fine.

Can anyone please point what's wrong with this scenario and how to resolve this?

Update: Attaching package-solution.json code

{
  "$schema": "https://developer.microsoft.com/json-schemas/spfx-build/package-solution.schema.json",
  "solution": {
    "name": "my-app-client-side-solution",
    "id": "xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx",
    "version": "1.0.0.0",
    "includeClientSideAssets": true,
    "isDomainIsolated": false
  },
  "paths": {
    "zippedPackage": "solution/my-app.sppkg"
  }
}
4
  • can you share your package-solution.json code. Also do you see the deploy button on Ribbon disbaled after selecting the app in app catalog – Akshay Randive Sep 3 '20 at 15:16
  • 1
    We have same issue in our tenant and opened a case with Microsoft support. Its happening only for new sites created. – Vishwa Sep 3 '20 at 16:58
  • @AkshayRandive: No, as mentioned in the question, the button to deploy the app in the ribbon is not visible once I select the package in catalog. Also updated question with package-solution.json code. – Yayati Sep 4 '20 at 10:51
  • @Vishwa: Did you get any updates from Miscrosoft ? Is it resolved for you? – Yayati Sep 8 '20 at 6:16
1

We had same issue in our tenant and opened a case with Microsoft support.

Microsoft came back stating that user who enables the App catalog must be owner of the Site collection. Also, User must have SPO admin role and also admin of tenant app catalog site collection. It was not the case before, but they have changed the Add-SPOSiteCollectionAppCatalog cmdlet to work with below role/access requirements.

To run this cmdlet user must have the following roles:

  • SharePoint Admin role or Global Administrator role
  • Site Collection Administrator of the tenant app catalog
  • Site Collection Administrator of the site collection of the site specified in the -Site parameter

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.