0

I have a problem when send invitation to a teamsite to user from SharePoint2013 Enterprise. In the Outgoing E-Mail settings I have set a from address apps.teamsite@xxxx.com. In the descpritopn of Mail Settings says “ Specify the SMTP mail server to use for Microsoft SharePoint Foundation e-mail-based notifications for alerts, invitations, and administrator notifications. Personalize the From address and Reply-to address” so the From address might be the one used.

When I invite a user to a site/SharePoint Group I get a mail from myself (my mail address instead of the apps.teamsite…address) saying I invited the user and a mail is also sent to the invited user. Now starts our problem. We have users in our domain from another mail domain with another mail suffix, @yyy.com. Our external mail router is not accepting mail not coming from our internal mail domain. In this case the user inviting a user has the mail address aaa.bbb@yyy.com and the user inviting gets an error message from the mail router system saying the mail could not be sent. The inviting user gets worried that the access is not working correct. Why isn’t the From Address setting used as the From address? Can this be fixed so the mail comes from the apps.teamsite@xxxx.com?

0

Sending as the inviting user is the default behavior of SharePoint Server 2013+, however this can be adjusted in SharePoint Server 2016+ starting with the August 2017 update, KB4011244, though I would recommend you apply the latest PU to your farm:

KB4484476

KB4484473

You can then apply the change at the Web Application level:

$wa = Get-SPWebApplication https://webAppUrl
$wa.OutboundMailOverrideEnvelopeSender = $true
$wa.Update()
3
  • I will update the Environment with the the latest PU as you meantioned. Question? Regarding default, in the Outgoing email settings it says "Specify the SMTP mail server to use for Microsoft SharePoint Foundation e-mail-based notifications for alerts, invitations, and administrator notifications. Personalize the From address and Reply-to address." - But still it seems that the default setting is to use the user that invites, correct? What address should then be used to fix that for the Web Application? Will that act different and use that address instead of the inviting users address? – user65250 Sep 7 '20 at 13:36
  • You need to run the cmdlet I posted for it to come from the Reply To address specified in the outgoing email settings for invites. – Trevor Seward Sep 7 '20 at 17:59
  • 1
    Works great with the script. Thanks. Problem Solved . . – user65250 Nov 4 '20 at 12:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.