0

We have setup a document library in SharePoint Online that includes metadata columns to drive a regular review cycle - for example, the documents keep track of last reviewed date, review status, document owner and document approver. The owner of the document will enter this information when the document is first uploaded.

This all works quite well except for in one scenario: when the end user uploads a brand new copy of the file, from an offline copy on their local machine. This might occur when the organisation publishes and mandates the usage of a new document template (including new logos, color schemes, etc) - the user downloads the template, and then copies the existing document content into the new template. When the user uploads the new version of the file, the metadata is removed from the document in SharePoint and the review cycle on that document is essentially broken.

Now I understand this is due to the Property Promotion/Demotion feature and cannot be disabled in SharePoint Online. With this in mind, are there any other ways we can get around this particular problem?

1

Refer to this article, we can disable property promotion in SharePoint On-premises versions only, not in SharePoint online.

| improve this answer | |
  • Thanks, we already understood this. I'm guessing there's no way around this at this time? – DRVR Sep 1 at 23:15
  • 1
    Currently there is no workaround for it. – Julie_MSFT Sep 3 at 1:58
0

Do you use a custom content type? If so, is the new version also uploaded with the same content type?

You mention that the new version contains the copied contents. Do you also copy the properties from the original document? (under File > Info > Properties) Paul

| improve this answer | |
  • Yes, It's a custom content type - the library we are using only has the one content type. Regardless, we don't copy the properties from the SharePoint copy of the document, as the 'new version' of the document was created on the end-users local machine (no custom properties) and then uploaded. – DRVR Sep 1 at 23:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.