0

Anonymous user are able to view page(sitepage/main.aspx) in sharepoint 2013 on-premise.

(main.aspx contains HTML file, JS file, script editor, list web part called "mydata" with view "myview").

But the problem is as soon anonymous user set the filter for any column, a login prompt is shown. I want to get rid of the login prompt even when filter is applied.

things I tried:

  1. Anonymous user enabled at central admin
  2. anonymous user enabled at site collection
  3. anonymous user has permission for the list/html/images/css/js (and all items that render on main.aspx) etc (by breaking inheritance and grant anonymous access)
  4. also anonymous user has access to folder/directory where these images/js etc are stored
  5. enabled check-in and publishing
  6. all items/assets are published
  7. disabled Limited-access user permission lockdown mode (in site collection features)
  8. iisreset

Update 1: When I see console after "cancel" login prompt I see:

http://myurl/_layouts/15/inplview.aspx?List={7798XXXX-6662-43CF-A90E-2A195XXXXXXX}&View={EC8A0306-XXXX-48C8-AA93-6EEF5EEXXXXX}&ViewCount=0&IsXslView=TRUE&IsCSR=TRUE&FilterField1=Sector&FilterValue1=designation

Failed to load resource: the server responded with a status of 401 (Unauthorized)

0

This is because you did not grant API access to your anonymous users; so what you have done is needed, but not yet enough.

You have to uncheck Require Use Remote Interface option from your site collection settings. Do the same thing through Central Administration (Manage Web Application -> Authentication Providers).

(I do not remember the differences betweeen 2013 and 2016 but it should help you!)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.