0

I've setup a new my site page for a client on SP 2013. I'm having trouble getting the profile pictures to update. After searching here at stackexchange and google I see some info about this but nothing specific to my issue. When I run this PS command...

Update-SPProfilePhotoStore -CreateThumbnailsForImportedPhotos 1 -MySiteHostLocation https://my.companyname.org

...to import images I get this error.

Update-SPProfilePhotoStore : UserProfileApplicationNotAvailableException_Logging :: UserProfileApplicationProxy.ApplicationProperties ProfilePropertyCache does not have 5a932038-8da6-4009-aac0-4e4aa1e7013e

It appears there is something wrong with the UserProfileApplicationProxy but I'm not sure how to resolve the issue? Any and all help is greatly appreciated. Here are SP's log entries.

08/11/2020 09:48:41.80 powershell.exe (0x21E0)
0x4948 SharePoint Portal Server User Profiles
g11n High UserProfileApplicationProxy.InitializePropertyCache: System.NullReferenceException: Object reference not set to an instance of an object. at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.IsCompatibleDatabaseSchema(ProfilePropertyData propertyData) at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.RefreshProperties(Guid applicationID) at Microsoft.Office.Server.Utilities.SPAsyncCache2.GetValueNow(K key) at Microsoft.Office.Server.Utilities.SPAsyncCache2.GetValue(K key, Boolean asynchronous) at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.InitializePropertyCache() d88a8353-d8d3-4235-8eb5-137f167a1f88

08/11/2020 09:48:41.86 powershell.exe (0x21E0)
0x4948 SharePoint Foundation PowerShell
6tf2 High
Microsoft.Office.Server.UserProfiles.UserProfileApplicationNotAvailableException: UserProfileApplicationNotAvailableException_Logging :: UserProfileApplicationProxy.ApplicationProperties ProfilePropertyCache does not have 5a932038-8da6-4009-aac0-4e4aa1e7013e at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.get_ApplicationProperties() at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.CheckAdministrationAccess(UserProfileApplicationAdminRights rights, Boolean requireAllRights) at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.CheckAdministrationAccess(UserProfileApplicationAdminRights rights) at Microsoft.Office.Server.UserProfiles.ProfileManagerBase.CanManagePeople(UserProfileApplicationProxy userProfileApplication... d88a8353-d8d3-4235-8eb5-137f167a1f88

08/11/2020 09:48:41.86* powershell.exe (0x21E0)
0x4948 SharePoint Foundation PowerShell
6tf2 High ...Proxy) at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.get_IsProfileAdmin() at Microsoft.Office.Server.UserProfiles.ProfileManagerBase.get_IsProfileAdmin() at Microsoft.Office.Server.UserProfiles.UserProfileManager..ctor(SPServiceContext serviceContext, Boolean IgnoreUserPrivacy, Boolean backwardCompatible) at Microsoft.Office.Server.UserProfiles.UserProfileManager..ctor(SPServiceContext serviceContext) at Microsoft.Office.Server.UserProfiles.PowerShell.SPCmdletUserProfilePhotoStore.InternalValidate() at Microsoft.SharePoint.PowerShell.SPCmdlet.ProcessRecord() d88a8353-d8d3-4235-8eb5-137f167a1f88

08/11/2020 09:48:41.86 powershell.exe (0x21E0)
0x4948 SharePoint Foundation PowerShell
91ux High Error Category: InvalidData Target Object Microsoft.Office.Server.UserProfiles.PowerShell.SPCmdletUserProfilePhotoStore Details NULL RecommendedAction NULL d88a8353-d8d3-4235-8eb5-137f167a1f88 08/11/2020 09:48:41.93 powershell.exe (0x21E0) 0x4948 SharePoint Foundation PowerShell 6tf0 Medium Leaving ProcessRecord Method of Update-SPProfilePhotoStore. d306cd8e-683f-0000-889b-61d33f68d601

08/11/2020 09:48:41.93 powershell.exe (0x21E0)
0x4948 SharePoint Foundation PowerShell
6tf0 Medium Entering EndProcessing Method of Update-SPProfilePhotoStore. d306cd8e-683f-0000-889b-61d33f68d601 08/11/2020 09:48:41.93 powershell.exe (0x21E0)
0x4948 SharePoint Foundation PowerShell
6tf0 Medium Leaving EndProcessing Method of Update-SPProfilePhotoStore. d306cd8e-683f-0000-889b-61d33f68d601

Thanks

0

As it turns out I wasn't running the PS console as the correct user. I opened the PS prompt as the SP 2013 Farm Admin and it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.