1

I've built several SPFx web parts but now I'm getting errors because I'm "somehow" on node v12 which I don't believe works with SPFX. I certainly didn't update it so how has it switched to v12 and how do I prevent this from happening again?

0

Some programs need a specific version of node for their work and while you install them, they silently install node of the version they need. To prevent it in the future, I'd recommend using nvm - Node Version Manager. It allows you having multiple versions of node in your computer and switch between them easily.

Installing node v.12.14.1:

$ nvm install 12.14.1

Using node 12.14.1:

$ nvm use 12.14.1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.