I'm trying to host the JS files (webpart\temp\deploy) of my web-part in the asset library folder, but I'm not able to reference that in the config files.

In which file I have to defined that path? the web-part on deployment keep showing me deploying.

This client side solution will get content from the following domains: https://localhost:4321/.

2 Answers 2


If you are looking for hosting your client-side web part from Microsoft 365 CDN then check below references:

  1. Host your client-side web part from Microsoft 365 CDN
  2. SharePoint Framework - Deploy SPFx WebParts To Office 365 Public CDN
  • Thanks for the response, I read both links but not able to get the settings correct. I set the path in the cdnBasePath write-manifest.json but still showing me localhost when I try to upload the package. Thanks, -Sal
    – ejagkrch
    Jul 22, 2020 at 18:08
  • Are you deploying your package to SharePoint app catalog or just running gulp serve and trying it in local workbench? Try deploying your webpart to app catalog. Jul 22, 2020 at 18:12
  • i'm uploading it to SharePoint App catalog and set the CDN path to the asset library folder in the same site but on while I'm uploading it says it will get content from localhost and the web part that it display does not load , as I assume its not picking up the files from asset library.
    – ejagkrch
    Jul 22, 2020 at 18:19
  • Have you setup the Microsoft 365 CDN? Jul 22, 2020 at 18:24
  • Yes, I did. and shows me in public CDNs when I run the command.
    – ejagkrch
    Jul 22, 2020 at 18:58

Have you used Production build or plain build?

Seems, if you do not use --ship or --produciton flags while packaging, "includeCleintSideAssets" flag is ignored

enter image description here

Additional reference here = "gulp package-solution" will raise this warning "- [package-solution] This is not a production build (--ship or --production).."

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.