0

We are having SharePoint 2016 environment and since some time , not sure how long ago, we have a problem with one web application which cannot be crawled. Only for the site collections which are part of that particular web application we are getting this message :

"This item could not be crawled because the repository did not respond within the specified timeout period. Try to crawl the repository at a later time, or increase the timeout value on the Proxy and Timeout page in search administration. You might also want to crawl this repository during off-peak usage times.( SearchID = CF42662C-56A9-4B5D-B872-035186D6CADE )"

I saw dozens of asked question for this exactly same message but none of them have provided solutions that worked for us:

1.Changing the Timeout change value ( I have changed even up to 220s, no change ) 
2.Changing the IE proxy settings with un-checking the Automatically detect Settings ( Lan Section)
3.Disabling the the Firewall

I have also tried to find something in the ULS logs for that particular search ID but I was not successful , I havent set verbose logging still , thats my last option if someone of you have no other idea what can be the problem. Nothing is different than the other web applications and their site collections judging by the setup of the search service accounts, the access of that search account over the content etc. We have noticed this problem after a customer complained that he cannot search items inside his created library.

Any proposal aside the already available ones which I have mentioned here can be helpful for me.

Thanks!

0

I had a similar issue on SharePoint 2019 like a year ago, when I was setting up the search.

Couldn't find anything in logs, everything seemed perfectly fine, in the end I found up it is being blocked by McAfee Antivirus/Firewall. If you have any kind of AV/FW except the MS native one, try disabling it all.

1 more thing - As I have found the issue, customers IT has enabled it, uninstalled and it still did not work, they had to install the McAfee again, disable the firewall and then uninstall.

Let me know if that helps.

3
  • Thank a lot for your provided idea Marek, I would try it even though it does not look so convincingly for me as solution for our problem, as if the problem was with the Antivirus the it would have been present for all web applications, not for only this one, but as I have said I would try it and let you know. – JovicaS Jul 20 '20 at 10:48
  • Hey MarekI have found the problem and was unbelievably simple,but it made me spent couple of days of checking almost everything and looking on many different directions. The problem was the name of the web application added in the content source,yes,I know its stupid but,the wrong name added was class.com and it should have been claas.com .I really checked the content source as a first thing but obviously i didn't put attention on the naming.I feel so bad,but I learned that in many cases the problem is right before your nose and you should just open your eyes,more:) – JovicaS Jul 29 '20 at 7:42
  • haha, glad you solved it :) have a nice day – Marek Kyzivát Jul 30 '20 at 7:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.