I am entering the below condition as the validation formula for an attribute in the SP list, but it allows me to enter "innovation" instead of "Innovation", how can I avoid this.

 =OR([Asset type]="Innovation",[Asset type]="Communication")

enter image description here

  • What is the data type of Asset type column? Do you want your users to enter only Innovation or Communication in Asset type then you should consider creating choice column for this. Jul 16 '20 at 8:30
  • Because I have created the flow and I do not want to change them, so is there any way to make it case-sensitive without changing the type? the type is "single line of text" and unfortunately also it is a title, so I cannot make it a dropdwnlist, unless I can move the properties of a title to another column (sharepoint.stackexchange.com/questions/280467/…), btw thanks Jul 16 '20 at 8:36

Try using the same formula in list validation settings.

  1. Go to List settings
  2. Click on Validation Settings
  3. Enter your formula and Save.

If this formula is not working then try using this:

=IF(OR([Asset type]="Innovation",[Asset type]="Communication"), true, false) 


  1. Sometimes comma(,) does not work in formula (I am not sure but it is based on something language or regional settings on your site). So in that case use semicolon(;) instead of comma(,).
  • This does not work, I have added more screenshots, even if I remove the formula validation in the edit column section and rely only on the validation settings, still allows me to enter innovation – Jul 16 '20 at 19:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.