0

Im having the same issue reported in this question Upgrade Site collection to 15 in SharePoint 2013 Failed

After the process of Mounting the content dabase, everythins was working fine, but when I tried to the visual upgrade, i get errors on the subsites Feature upgrade action 'CustomUpgradeAction.EnsureVariationsInfrastructure' threw an exception upgrading Feature 'Publishing' (Id: 15/'22a9ef51-737b-4ff2-9346-694633fe4416') in Web xxxxxxxxx Exception: Invalid field name. {8484dbaf-e6d2-4f98-9aa7-e19f89260224} /Variation Labels 0304649f-8ac5-a0ef-52b4-0d9dee0f3098

Has anyone been with this error.

On this SharePoint 2013 farm, I already upgrade another web application, coming from the same SP2010 Env, also with variations configured and with no problems.

  • Did you install any required language packs? Did you execute Test-SPContentDatabase to verify possible errors? Also, make sure the database transaction log is not full and has enough free space. – Prasanna Jul 14 at 23:37
  • Language packs installed, and the vm has enough disk space, i even put the transaction log to the database to simple. – João Silva Jul 15 at 7:26
0

This was solved, after setting the VerboseEx loglevel, it showed an error not finding the "Variations Label" list, it was searching the name in portuguese. "Translation.Provisioner.AddVariationTransactionColumns Site does not contain Variations Labels List. List "Etiquetas de Variação" does not exist.

Changed the locale to en-us on the site collection, started a new upgrade and everything worked ok.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.