0

Will anyone know the possible reasons why in a SharePoint online 'List site' page a column appears in the View settings (i.e when creating or editing current view) BUT it doesn't appear as column in the List Settings of the site?

I should let you know that you know that the column in question seems to have some flow behind it which I can't see.

enter image description here

2
  • I ran into the same issue when writing a template for json, I had to target the column using the internal name. No idea why it does not show up in the list settings. – hittle08 Jul 13 '20 at 14:02
  • What is the work around? And this column of mine doesn't even export to excel. It used to but all of a sudden it stopped. A lot of users have access and not sure if anyone played and did something that made this problem – Nadim Jul 13 '20 at 22:36
0

There are certain columns which are related to some other services. For example, the column "Item is a record" (internal name "_IsRecord").

The above column is related to the 0365 compliance center and its value depends upon whether a compliance tag is assigned to the document, and if the compliance tag has converted the item into a record or not.

There are other similar examples such as "Retention label".

Can the column you are describing in your question be one of such columns?

2
  • Sourav thanks for the comments. How do I figure out whether it is one of those cases? – Nadim Jul 13 '20 at 22:35
  • Is a a custom column where you are facing this issue? Or is it an inbuilt column? In case it is an inbuilt column, which one is it? Sorry, the picture in your question is not clear for me – SOURAV MUKHERJEE Jul 14 '20 at 6:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.