0

I have a landing page with a content search webpart that I want to be dynamically filtered by an URL like this one http://mysharepoint.com/site1/home.aspx?tagterm=#0a1658abf-cc9d-495c-a8cc-e25953aad57e. It should be grabbing the term GUID from the term store and filtering upon it in the query below but it returns nothing after I save close the query dialog box. While editing the query the and testing in the TEST tab it works perfectly. Am I missing some sort of special encoding from the URL? I added some visual examples below.

enter image description here

The query:

owstaxidmetadataalltagsinfo:{QueryString.tagterm} (contentclass:STS_ListItem OR IsDocument:True) (ContentTypeId:0x010100B49CA5009A6365469E63CD3AC5F1FDA8* OR ContentTypeId:0x01010A00ED2A591570802345BA22687CF8A919F1*)

Results from the TEST tab enter image description here

Why would results return in test but not from the URL?

2
  • Where is the URL mysharepoint.com/site1/… refering to? You can search in search box. Jul 6 '20 at 10:25
  • @LisaChenMSFT the page is referring to a landing page with 3 CSWPs. Above is one of the webparts. A search box would not give me the results like I want them. The goal is to have some favorite topic links that can be selected and that would produce a dynamic page of content all across the webapp that was tagged with that topic. It works as expected in the TEST tab of the Query Editor but not live on the page. Jul 6 '20 at 11:15
0

I found out the issue is that there needs to be a leading 0 to the term.

a1658abf-cc9d-495c-a8cc-e25953aad57e -> 0a1658abf-cc9d-495c-a8cc-e25953aad57e

The url now looks like http://mysharepoint.com/site1/home.aspx?tagterm=0a1658abf-cc9d-495c-a8cc-e25953aad57e

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.