First of all I apologize for my bad English.

If a user opens for example an xlsx file with chrome he downloads it. From now on it is no longer connected to the uploaded xlsx file and changes will not saved. That's exactly not what I want Chrome to do. The file should be opened on the client with Excel and still connected to the file which was uploaded on the server. With IE it all works fine.

I've done some research and didn't find any solution which works for me. The OpenInClient feature is activated. Many thanks for your help.

Solution: There is no solution for this problem. Chrome can't handle files the way i want Chrome to handle. You need to use another browser (IE, Firefox, Opera etc.).

  • I am looking for this answer. I have a chrome instance that opens new workbook in a new tab, in chrome as intended. On another computer, it downloads. This has to be a chrome setting somewhere. Jul 18, 2022 at 13:23

1 Answer 1


This is how Chrome handles file downloads. Unfortunately, no workaround for this. If you want to automatically open files from SharePoint to be worked in and saved back up to SP within the browser, you'll need to use a browser like Internet Explorer or Firefox.

  • I was already afraid of that. Thank you for the fast answer. Jul 3, 2020 at 5:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.