0

I have an Expense report App this app is based on 2 Sharepoint lists: 'Expenses' ; 'LineItems' and a PowerAutomate flow (see below). I can't seems to call the data from LineItems from PA (I would need to show the expense line item in an email to the approver). The 2 lists are linked via lookup column- I am not sure if that is enough.

Calling the LineItems list by the GetSharepointItem in PA return the following error (no filter applied):

InvalidTemplate. Unable to process template language expressions in action 'Get_items' inputs at line '1' and column '2854': 'The template language expression 'json(decodeBase64(triggerOutputs().headers['X-MS-APIM-Tokens']))['$connections']['shared_sharepointonline_1']['connectionId']' cannot be evaluated because property 'shared_sharepointonline_1' doesn't exist, available properties are 'shared_sharepointonline, shared_approvals, shared_office365'. Please see https://aka.ms/logicexpressions for usage details.'.

I am not sure how to proceed, here are the list and the flow chart:

EXPENSES EXPENSES

LINEITEMS LineItems

FLOW CHART PowerAutomate

EXPENSES view Title --I notice Child count are all at 0 enter image description here

LINEITEMS lookup Title ID view Lookup Title ID

TEST FILTER

Test calling LineItems with filter

0

you cannot have lookup columns in Power Automate. Instead create a number column and store the ItemID of linked items against your line items. you can use the ODATA query filter in flow to match original item id with value stored aganist list column. You can make column read-only in list view. or hide it.

| improve this answer | |
  • I think I already have this link between my 2 lists view added pictures. I am not sure how to use the data in the Flow as it return this error to me when I try to call for the LineItems table. I guess my problem is that I have trouble calling data from 2 different lists with Flow – Guillaume Jul 1 at 17:26
  • I understand, but, PowerAutomate cannot recognize these columns as they are added as Lookup. PowerAutomate doesn't support LookUp columns as of now – Akshay Randive Jul 2 at 3:46
  • Understood, I added an ItemID column in LineItems and manually added value to test it. I obtain the same error when I called the list via Flow with theese 2 filters : {ItemID eq 'GetItems_FilterQuery'} (see picture) and {ItemID eq '13'} – Guillaume Jul 2 at 15:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.