0

SharePoint 2013. SharePoint Designer 2013 (version 15.0.4849.1000).

When creating a 2013 Workflow in SharePoint Designer, the condition "The File Type is a Specific Type" is not in the list of available conditions.

From what I have read, this condition should be an available option when creating a workflow but I don't see it. I haven't been able to figure out why.

I have confirmed I have the most up to date version of SharePoint Designer 2013. I tried clearing the SharePoint Designer Cache. I tried preventing SharePoint Designer from using the cache. I have tried creating workflows from different lists including a Documents library and a Drop Off Library among others.

I reviewed information from these pages among others:

Condition and action missing from Workflows in SharePoint designer 2010

https://docs.microsoft.com/en-us/sharepoint/dev/schema/default-workflow-actions-workflowinfo

On the server, I noticed that the WSS.ACTIONS file (in C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\TEMPLATE\1033\Workflow) has a condition with the name "The file type is a specific type" and that the workflow15 file in the same folder does NOT have this condition (but it appears to have other conditions).

Could this be a problem with the workflow15 file? Or can anyone think of any suggestions to try?

I'm most grateful for any thoughts or guidance anyone can provide. Thank you!

0

The file type is a specific type conditions is only available in SharePoint 2010 platform workflow.

The file type is a specific type conditions is available only when your workflow is associated with the Document content type, a child of the Document content type, or a library.

Reference:

https://support.microsoft.com/en-us/office/workflow-conditions-in-sharepoint-designer-2010-a-quick-reference-guide-d8e33ac7-9336-487f-a60b-388c4ea497ff?ui=en-us&rs=en-us&ad=us

| improve this answer | |
  • I just tried creating the workflow as a 2010 workflow instead of 2013 and sure enough the option was there. Thanks, Lisa! – Lothar Jun 24 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.