Yes, I am still trying to work in InfoPath. I created 4 separate InfoPath Forms to be used in one list. I thought the easiet way would be to create separate InfoPath forms and apply as Content Type to the list. But when I apply as content type the metadata columns from the form do not appear in the form library even after modifying the list for the columns to appear. I made sure the content type had the fields too. When you just one form and publish to the Form library it appears with the metadata columns.

Can you help me to find a way for the metadata to appear in the Form library columns? Is there a better way to use more than one InfoPath form in one Form library and whatever information entered in the form to appear in the Forms Library?

1 Answer 1


For your scenario, follow the below steps :

  • You can develop four separate infopath forms, preferably you can pick blank form template.

  • Publish these as content type or deploy to farm level.

  • Active these forms as separate four site collection level features.

  • Create a form library. From the form library setting, go to advanced settings, select allow content type.

  • Add the above four infopath form content type.

  • Done

How can we display the infopath form column as metadata in the form library?

While publishing the each infopath form, in one of steps, we can see promote the columns, so whichever columns we select as promoted columns during publishing the form, we can see those form columns as metadata in the form library for the respective content type.

  • Thanks. I tried but each time I published content type form the form overwrites the previous published form. Any suggestions? Commented Jun 3, 2020 at 21:46
  • 1
    It is the default behavior... each time you publish the form, the content type gets replaced.. however, it will not impact your already saved data to the form library using the previous version of same content type.
    – SP 2022
    Commented Jun 4, 2020 at 14:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.