0

Goog day,

I have the problem with site import between two site collections. SharePoint 2016. The site collections are from same SP Farm. I exported the site "http://Coll1.xxx.com/career" using the Central Administration. In the Central Administration, I went to Backup and Restore > Export a site or list. Choose my site "http://Coll1.xxx.com/career", and click Start Export. The Career.cmp and Career1.cmp files were created. I run Import-SPWeb -Identity "http://Coll2.xxx.com/career" -Path c:\Career.cmp -UpdateVersions Overwrite

I saw the error: The DateTime represented by the string is out of range.

Ok, I exported career.cmp file to my desktop and changed the extension .cmp to .cab Then I changed

to

Now I repackaged it as a .cab file. I used a software called CabPack. Changed the extension .cab to .cmp

Run the command:

Import-SPWeb -Identity "http://Coll2.xxx.com/career" -Path c:\Career.cmp -UpdateVersions Overwrite

Get the error: the version of the package is different from the current version this program supports, 15.0.0.0

Ok, I open the SystemData.XML file with an editor like NotePad++ And I see

<SchemaVersion Version="15.0.0.0" Build="16.0.4783.1000" DatabaseVersion="4108407" SiteVersion="15" ObjectsProcessed="579" />

I can't understand what can I change in SystemData.XML, if Version="15.0.0.0" The Error message doesn't include information: "the version of the package ??? is different"

Would be grateful for any help.

  • The question is still actual. I use the script codecaching.blogspot.com/2012/11/… I get this: Cannot find path 'C:\TMP\Career\Manifest.cmp' because it doesn't exist. I have 51 Career.cmp files. – Anonymous Jun 1 at 16:39
  • I opened site settings->site administration->Regional settings. They are same for Col1 and Col2. TimeZone (UTC+03:00) <my city> (RTZ 2) I opened regional settings for Farm PC Windows 10. I see Format: Short date: dd.mm.yyyy Long date: d MMMM yyyy 'y' Short time: H:mm Long time: H:mm:ss First day of week: Monday Location: my country. I don't understand which time settings are wrong. – Anonymous Jun 1 at 16:42
0

I found the solution. I use -NoFileCompession.

I run

Export-SPWeb -Identity "My Site URL" -Path "My folder path" -NoFileCompression

I get files without compression, then I change in Manifest.xml

Then I run Import-SPWeb -Identity "My Site URL" -Path "My folder Path" -NoFileCompression

And the site was imported without problem.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.