1

Here is the scenario (both TEST and Prod SP is 2013 farm)

  1. I had DBA take a fresh copy of the PROD site collection DB and restore it TEST DB
  2. Then I used following to provision the site in TEST.

stsadm -o addcontentdb -url https://inside.colage.com/sites/OPS -databasename SP2013_CD_OPS -databaseserver EXTSPSQL

  1. The ran successfully
  2. I waited a while and it gives me following error

https://inside.colage.com/sites/OPS

Server error: http://go.microsoft.com/fwlink?LinkID=177673

1 Answer 1

0

you dont need to specify the Site collection url rather you need to provide the web application url.

stsadm -o addcontentdb -url https://inside.colage.com -databasename SP2013_CD_OPS -databaseserver EXTSPSQL

It will add the database into the Web application, after sucesffuly attaching it then go to the browser and browse the url.

Or you can use the SharePoint Powershell to attache it:

Mount-SPContentDatabase "SP2013_CD_OPS" -DatabaseServer "EXTSPSQL" -WebApplication https://inside.colage.com
6
  • i ran the stsadm command. Operation successful. when I browse I receive same error.
    – ruby
    May 19, 2020 at 20:35
  • can you check from central admin > Web application management > View Site collection > select the desired web application & make sure you are seeing your site collection their.
    – Waqas Sarwar MVP
    May 20, 2020 at 3:06
  • Site collection did not get created this time. I did a dis-mount and tried both of your command and none of them created the site collection. both said operation successful.
    – ruby
    May 20, 2020 at 13:54
  • their could 2 possible things, 1- site collection with the same url already in the test farm. you can dismount the database then check if you can see site collection via central admin. 2- backup / recovery of the database was not sucessfull on sql server. after mounting the database, can you go CA >application management> manage content database, Select desired web application....on this page can you see your Database and how many sites it shows
    – Waqas Sarwar MVP
    May 20, 2020 at 14:09
  • 1. verified URL doesn't exist not duplicate GUID in the config db 2. Backup/Restore may be the root cause 3. Content database screen shows 0 site collection 4. application view all site collection doesnt show the site . I tried these steps but did not resolve sharepointdiary.com/2016/01/…
    – ruby
    May 20, 2020 at 14:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.