0

I have a single server farm running SharePoint 2016.

  1. Under Health Analyzer: Distributed cache service is not configured on server. I ran add-spdistributedcacheserviceinstance, reanalyzed and same error.

  2. Under Health Analyzer: Server Role configuration isn't correct. I clicked repair automatically, reanalyzed and same error.

I went to Manage Services on Server and Distributed Cache compliant is No. I manually clicked start for the service and it doesn't start. Clicking fix does nothing. The AppFabric Caching Service under services some is set to disabled. I enable under services, repeated steps and same issue. Get-CacheHost shows AppFabric Caching Service "UP."

How can I get this service started?

0

This was fixed by running the following commands:

  1. remove-spdistributedcacheserviceinstance
  2. add-spdistributedcacheserviceinstance
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.