0

Situation: I have a simple 2013 workflow that runs on List A. The last step in that workflow triggers a simple 2010 workflow on List B. The 2010 workflow runs on List B normally and ends successfully (Completed). The 2013 workflow that triggered the 2010 workflow never ends; it stays in “Started” status.

According to the information log, the error seems to be related to the associationName. Here's what the message says:

Suspend this workflow

Activity in progress

Retrying last request. Next attempt scheduled after... Details of last request: HTTPBadReuest to URL Correlation Id: 2e39fa46-3b1e-f5cd-9270-62564cd3b063 Instance Id: 85d11605-c9a7-4905-98ae-17e3e5fece04

associationName

Retry now

Note: I have seen at least two different correlation Ids.

Overview:

  1. List A – User creates or edits an item.
  2. List A – 2013 workflow starts and triggers 2010 workflow on List B.
  3. List B – 2010 workflow is triggered by List A, runs, and completes.
  4. List A – 2013 workflow does not progress past the trigger (Start 2010 Workflow with no parameters on Current Item (output to Data source).

I have tried a number different things to resolve the issue including: testing with workflows that only contain one stage/step and one or two actions, manually ending and restarting the workflows, wrapping the 2010 workflow trigger in an App Step, and setting the "Wait” property on the Start Workflow action to "No." None of this has resolved the issue.

I think I might need to set the AssociationName property somewhere on the 2010 workflow, but I don't know where (and I have looked).

I also tried this: Calling SP 2013 workflow not resuming after completion of called SP 2010 workflow. I found several other online articles that describe similar issues, but none of them match this scenario.

Nothing has worked, all suggestions are greatly appreciated!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.