2

The crawls in Sharepoint 2016 were failing to capture updated documents, so I tried Index Reset and recrawled the site. Now the crawls generate IndexOutOfRangeException errors on every document in the site. The Service Service generates identical errors, such as the ones below. The Search Schema page in CA displays "An unknown error occurred." Should I delete and recreate the Search Service Application?

05/08/2020 01:57:08.62  NodeRunner.exe (0x0F9C)                     0x2CA8  SharePoint Server Search        Administration                  ah33p   High        Exception while reading all managed properties from schema for SSA f9521cda-779e-4021-886b-5c9ae0eec679: System.IndexOutOfRangeException: ExpandSegments     at System.Data.ProviderBase.FieldNameLookup.GetOrdinal(String fieldName)     at System.Data.SqlClient.SqlDataReader.GetOrdinal(String name)     at System.Data.SqlClient.SqlDataReader.get_Item(String name)     at Microsoft.Office.Server.Search.Administration.SchemaDatabase.CreateManagedPropertyFromRow(Schema schema, IDataRecord record)     at Microsoft.Office.Server.Search.Administration.SchemaDatabase.PrivateGetManagedProperties(Schema schema)     at Microsoft.Office.Server.Search.Administration.SchemaDatabase.WrapFunction[T](String functionName, Func`1 wrappedFunction)     at Microsoft.Office.Server.Search.Administration.ManagedProper... 26f75771-4ec3-4721-8707-d1dd6b262f1c
05/08/2020 01:57:08.62* NodeRunner.exe (0x0F9C)                     0x2CA8  SharePoint Server Search        Administration                  ah33p   High        ...tyCollection.Populate()     at Microsoft.Office.Server.Search.Administration.ManagedPropertyCollection..ctor(Schema schemaToUse)     at Microsoft.Office.Server.Search.Administration.Schema.EnsureManagedPropertiesIsInitialized()     at Microsoft.Office.Server.Search.Query.SharepointFlowSsaConfiguration..ctor(Guid ssaId) 26f75771-4ec3-4721-8707-d1dd6b262f1c
05/08/2020 01:57:08.62  NodeRunnerContent1-f9521cda-779 (0x0F9C)    0x3700  Search                          Common Processing               ai9of   Medium      [Microsoft.CrawlerFlow-746e36fe-f4bc-4911-b69d-6424527d3797] Microsoft.Ceres.Evaluation.Engine.ErrorHandling.HandleExceptionHelper : Evaluation failure detected:    Operator          : RetrieveSSAPropertiesOperator    Operator type     : RetrieveSSAPropertiesOperator    Error id          : 0    Correlation id    : 1f7203f2-7b37-4737-bb19-2770de77ab22    Partition id      : 0c37852b-34d0-418e-91c6-2ac25af4be5b    Message           : ExpandSegments    49691C90-7E17-101A-A91C-08002B2ECDA9:#9: **URL of file**    id                : ssic://16990  System.IndexOutOfRangeException: ExpandSegments     at System.Data.ProviderBase.FieldNameLookup.GetOrdinal(String fieldName)     at System.Data.SqlClient.SqlDataReader.G...    1f7203f2-7b37-4737-bb19-2770de77ab22
4
  • I have recently resolved the similar issue ("An unknown error occurred.") by running the psconfig wizard, resetting the index afterwards and starting the full crawls. – Damjan Tomic May 8 '20 at 21:28
  • 1
    I've been reluctant to run the PSCONFIG command because I don't know the risks of crashing the system or wiping out the database. – carston1998 May 11 '20 at 12:50
  • PSCONFIG is a non-destructive fix to a lot of issues like upgrade failures. – Matthew McDermott May 11 '20 at 18:15
  • I have also seen unverified issues related to a CU. So you may want to determine your Database and File System health. The index uses the file system heavily. If you are out of disk space or installed the index to a small system drive you will run into these kinds of issues. – Matthew McDermott May 11 '20 at 18:17
1

I also had this issue due to a recent security update that the server team installed. It was actually a CU for SP2016 that impacted Search schemas. MS Support was assisting me in narrowing down the root cause. As an alternate to PSCONFIG, you can use the SharePoint 2016 Products Configuration Wizard to complete the CU deployment and ensure that the database version is correct. I performed this last night and no longer have these Search-related errors. Now to add this to my Server Administration guide for future troubleshooting and support!

0

I had PSCONFIG run on the server and it solved the problem. Thanks for all the suggestions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.