0

How do I give SharePoint Designer 2013 access to SharePoint Online?

When logging in on SharePoint Designer with a Global Admin account that has access as an Additional Admin on the site, I get an error:

"You do not have permission to access this site in SharePoint Designer."

According to this Dummies article, there is supposed to be a SharePoint Designer Settings option under Site Collection Administration section in Site Settings:

https://www.dummies.com/software/microsoft-office/sharepoint/managing-sharepoint-designer-access/

I do not see it there.

Any advice would be appreciated.

Thanks, A

0

You need to first click on "SharePoint Designer Settings" as shown in the pic below.

From Site Collection Administration page

Hope this helps!!

5
  • Thanks for this, although the setting did not appear there. I found out the reason as I do not have sufficient privileges to activate SharePoint Designer. I am a Global Admin. Would you know if I need to be anything else? May 1 '20 at 9:40
  • I am still getting this: !Valid XHTML. May 1 '20 at 10:10
  • @newbiecoder, just to be sure, you have checked that you are the Administrator for the Site Collection too? if you haven't; add your self to Site collection administrators.
    – Gary S
    May 1 '20 at 13:03
  • Would it have anything to do with the fact that these are all Teams connected sites I am unable to access through SharePoint Designer? May 5 '20 at 16:12
  • Thank you so much I found I couldn't modify the Primary Site Admin since it was a Teams connected site. I followed this article: jobs.collab365.community/… I am now able to access the site through SharePoint Designer! Thanks to all who contributed. May 5 '20 at 16:32
0

A few things you can try to narrow down this issue:

  1. Check if you have turned on the Custom Script option via Classic SharePoint admin center > settings > Custom Script (https://<tenant>-admin.sharepoint.com/_layouts/15/online/TenantSettings.aspx).
  2. Open the SharePoint Designer Settings page via this link and then select “Enable SharePoint Designer”: https://<siteURL>/_layouts/15/SharePointDesignerSettings.aspx

  3. If you still get error after enabling this option, install the Service Pack 1 for SharePoint Designer 2013.


UPDATE:

You are getting Access Denied error possibly because custom script is not enabled on the site level.

Please run the PowerShell commands below as a global admin.

Connect-SPOService -Url https://<tenant>-admin.sharepoint.com -credential admin@<tenant>.onmicrosoft.com

Set-SPOsite "<SiteURL>" -DenyAddAndCustomizePages 0
5
  • Thank you so much for the link, that helped me to see the SharePoint Designer settings as it was not listed under Site Collection Administration. I also found the reason, because as soon as I accessed the link and tried to apply any of the settings, I got an access denied error. I am a Global Admin on the tenant. Should I be anything else? May 1 '20 at 9:38
  • I am still getting this: !Valid XHTML. May 1 '20 at 10:11
  • @newbiecoder I've modified the answer. Please check the update. May 4 '20 at 8:38
  • I have checked and scripting is enabled. Thanks for that. Would it have anything to do with the fact that these are all Teams connected sites I am unable to access through SharePoint Designer? May 5 '20 at 16:13
  • Thank you so much I found I couldn't modify the Primary Site Admin since it was a Teams connected site. I followed this article: jobs.collab365.community/… I am now able to access the site through SharePoint Designer! Thanks to all who contributed. May 5 '20 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.