1

I've a SharePoint 2016 environment, Currently i've implemented MFA in the site, suddenly after implementing the site, I'm getting this error. "sorry this site hasn't been shared with you" enter image description here But, I'm the Site collection admin, and also the Farm admin. Also, i've ran PS config successfully.

Not sure, what went wrong after implementing MFA. Does anyone has faced the same issue, please help me with any solution.

1

You can try out the below troubleshooting:

  • Might be because of cached credentials from a prior browser session. Try clearing IE cache: Open a new browser window >> Go to Internet options >> In the general tab, click the Delete button >> Make sure that passwords and temporary Internet files are selected.
  • Try different browser such as Firefox! If you didn't run product and configuration wizard after installation/patch, you may get this error even if you are a site collection administrator. Run it once and get rid of this issue.
  • Stop and Start "Microsoft SharePoint Foundation Web Application" service from Central Admin >>Application Management >>Manage services on server. In case, you face issues, use STSADM command line.
  • Stop: stsadm -o provisionservice -action stop -servicetype spwebservice iisreset /noforce
  • Start: stsadm -o provisionservice -action start -servicetype spwebservice iisreset /noforce
  • If are migrated from SharePoint 2010, or backup-restore/import-exported: If your source site collection is in classic windows authentication mode and target is in claims authentication, You must change classic mode authentication to claims-based authentication (Convert-SPWebApplication or $WebApp.MigrateUsers($true))
  • If you have a custom master page verify its published! checked-out master pages could cause this issue. Try Check-in and make sure all resources such as CSS, Images, JS files are having atleast read access to all authenticated users.
  • If you have this feature enabled: "Limited-access user permission lockdown mode" at site collection level - Deactivate it. - Because, this prevents limited access users from getting Form pages!
  • Try clearing the Distribution Cache, Do the IIS reset.
  • On publishing sites: Make sure you set the cache accounts: Super User & Reader to a domain account for the SharePoint 2013 Web Application with appropriate rights

Source:

Fix "Sorry, this site hasn't been shared with you." Error in SharePoint 2013

Resolving “Sorry this site hasn’t been shared with you…” SharePoint site error:

| improve this answer | |
  • thanks for sharing the troubleshooting steps – Jegan Baskaran Apr 30 at 5:55
0

After a long struggle of troubleshooting and investigation, I found the solution for this issue, and posting it here, so it may be helpful to others.

While implementing MFA in out SharePoint site, it is expected that all our SharePoint user accounts should be in sync with Azure AD, however our existing accounts not actually Azure Identities, they are originally windows identities.

While setting the permission in SP site, we used to give the email ID / username of the user and it will get resolved to their windows identity format : contoso/firstname.lastname,

Whereas Azure AD account seems to be a different one, it contains the full email ID like firstname.lastname@contoso.com

I've replace the user account to Azure AD identity in the SharePoint group to resolve the issue.

Note: Azure accounts has a set of 5 entities and we need to add all of them in the SharePoint groups, as follows. • Azure AD name • Azure AD GivenName • Azure AD SurName • Azure AD Email • Azure AD Role

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.