I'm trying to connect data from Exchange 2010 to a SharePoint site through SharePoint designer, using the ASMX web services Exchange 2010 exposed as a Web Service data source.

I've already verified that there are no network issues and have verified that the WSDL is correctly read, but I keep getting this message:

<WSDL URL> did not return a valid description of an XML Web Service. Please check the address and try again.

I did go through several threads in social.msdn where they have found this problem, but neither of them was my issue at all, and on some the issue itself is not clear.

I also checked connecting to a SharePoint site web service and a third party application web service, they work correctly, but I can't spot anything weird in the Exchange WSDL.

Any suggestion on how could I troubleshoot this issue?


UPDATE: Based on the comments I think I'd clarify this: I verified that the URL does return a WSDL, and I've even gone to the point of sniffing the connection to make sure that SPD is reading the WSDL. Still, however, I am getting this error.

  • Do you have ?WSDL at the end of the web service URL? Commented Jan 27, 2012 at 23:38
  • @JohnChapman Not in this particular URL, because it does not need that in order to return the WSDL. (It does, however, expose a extension of .wsdl). One of the third parties software that I tried didn't used it as well, and I verified through Wireshark that SPD is requesting the same URL I introduce before trying the ?WSDL variant. Do you think that could be a problem?
    – Alpha
    Commented Jan 28, 2012 at 0:08
  • Try adding ?WSDL to the end of your web service URL as that tells IIS that you want the WSDL instead of the web service itself. Commented Jan 28, 2012 at 19:22
  • @JohnChapman I am getting the WSDL, that's for sure.
    – Alpha
    Commented Jan 28, 2012 at 22:19

2 Answers 2


It may be that the 3rd party tool automatically changed the url to something that would return a wsdl.

To check this take the url that you are using and request it from a browser. This should either give you a wsdl, a page with a link to the wsdl, or an error message.

If you get the page with the link, press the link and then use that url in SP Designer.

If you get an error message post it here.

If you get a wsdl, then there is something strange going on.

  • I think there is something strange going on. I did suspect of networking issues, security configurations or redirections, so I tested with an anonymous-accesible, reachable URL and did network sniffing over it. It is definitely returning a WSDL, but for some reason SPD will keep returning the same error.
    – Alpha
    Commented Jan 29, 2012 at 19:08

I've found the actual issue I was facing in this question. It actually is not related (or is it?) with SharePoint Designer more than it is related with the service itself.

In short, it turns out that the WSDL exposed by Echange 2010 lacks <wsdl:service> elements. Why is this happening, I am not sure, but I think it's outside of the scope of this forum. Still, now we know that SPD requires the service to be defined with that element in the service description despite other MS products not exposing it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.