2

I have an app that I've uploaded to the App Catalog. When I go to a site collection and request that app I get the message "Your tenant administrator has to approve this app" and I request the approval.

Now when I navigate to the App Requests list in the App Catalog and click the request, I don't get the Approve/Reject screen but only the edit screen for the approval request.

I have tried to change the status of the request to Approved but that doesn't work. When I go back to the Site Collection and go to the Apps you've requested I can see Approved but when I click the application it says "Invalid SharePoint App ID"

I'm doing this with a user that is a SharePoint Admin and Site Collection Admin on the App Catalog Site Collection.

I've used this same app in a lot of different tenants without any problems.

Step 1 - App Request List in the App Catalog

App Request list in App Catalog

Step 2 - The screen I get after I click the App Request in the App Catalog

Screen after I click the App Request

Step 2.a - The screen I should get when I click the App Request in the App Catalog

The screen I should get when I click the App Request in the App Catalog

Step 3 - What I see in "Apps you've requested"

Apps you've requested after Approval

Step 4 - After I click App Details in the "Apps you've requested" view

Invalid SharePoint App ID

After a long search I thought I struck gold when I saw a similar post here but the answer in that post does not work for me.

2
  • you need to click on the app itself and not the edit button :D Apr 24 '20 at 10:05
  • @GautamSheth Thank you for the response :) What do you mean by clicking the app itself? This is the App Request list and the only thing I'm able to click is the name of the app but that takes me to the edit screen :/ See updated screenshot for Step 1 Apr 24 '20 at 11:31
2

I also ran into this today in a tenant where the admin accounts didn't have a mailbox to receive the email in so I ran this PowerShell script to get the links instead.

$appCatalogUrl = "<URL to the tenant app catalog>"
$appRequests = Get-PnPListItem -List AppRequests -Query "<View><ViewFields><FieldRef Name='Title'/><FieldRef Name='UniqueID'/><FieldRef Name='Modified'/><FieldRef Name='AppRequester'/></ViewFields><Query><Where><Eq><FieldRef Name='AppRequestStatus'/><Value Type='Text'>Pending Permission</Value></Eq></Where></Query></View>"
$appRequests | fl @{name="Title";expression={$_["Title"]}},@{name="Requested By";expression={$_["AppRequester"].Email}},@{name="Requested";expression={$_["Modified"]}},@{name="Approval URL";expression={"$appCatalogUrl/_layouts/15/appapprovereject.aspx?requestid=" + $_["UniqueId"]}}

It lists all requests with pending permissions and displays the same URL as in the email that gets sent to the administrators. You can then copy the URL to your browser logged in as an admin and you should be able to approve the request.

2

For those who still struggling with App approval without email you can get App Request UniqueID with SharePoint REST API request:

https://{tenant}/sites/apps/_api/lists/getbytitle('App%20Requests')/items?$select=Title,UniqueId

Then substitute {UniqueID} without brackets here to get approval link:

https://{tenant}/sites/apps/_layouts/15/appapprovereject.aspx?requestid=%7B{UniqueID}%7D

0

This appears to be a bug with the approval list in the App Catalog. I have confirmed this behavior in two different SharePoint Online tenants. The link to the app for approval is going to the edit item page instead of the appapprovereject.aspx page.

There is currently a work around. All of the App Catalog site collection administrators receive an email when the app is requested for approval. In the email is the correct link that opens the Approve or Reject App request page. Use this link to approve the app, and then you should be able to add it to site collections as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.