0

i am using flow to create a folder in sharepoint document library and breaking the inheritance by using this .removing permissions:_api/Web/GetFolderByServerRelativeUrl('@{body('Create_new_folder')?['{FullPath}']}')/ListItemAllFields/breakroleinheritance(copyRoleAssignments=false, clearSubscopes=true) it works perfectly. Now when i want to assign permissions for a particular group by using the below uri in http it fails. it gives a message the URI is not correct. I am passing the correct principal id and role assignment id

 adding permissions fails:   _api/Web/GetFolderByServerRelativeUrl('{documentlibraryname}/{foldername}')/ListItemAllFields/roleassignments/addroleassignment(principalid=49,roledefid=1073741827)

what is wrong in this URI

0

Sorry Looks like a cache problem . When i tried once again like this it worked

_api/web/GetFolderByServerRelativeUrl('@{body('Create_new_folder')?['{FullPath}']}')/ListItemAllFields/roleassignments/addroleassignment(principalid=49,roleDefId=1073741827)
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.