1

I have been struggling with the following issue: I am trying to edit a SharePoint site, but whenever I click edit, I do not see the ribbon with the Browse and Page menus (the tutorials I have watched have that ribbon!) :(

I have read on the internet that I must switch to classic view, but I just cannot find the option!!!

I have basically installed SharePoint Designer in order to be able to freely edit my site, as I thought this would be the solution, but it is not working either.

I will put some links below with the view I am aiming to obtain:

https://www.youtube.com/watch?v=ZO655ZYHhQc https://www.youtube.com/watch?v=AeVeji8HFus&t=7s

enter image description here

2 Answers 2

0

From the home site page, we cannot see the option to Return to classic SharePoint We need to click on any list or library from home site quick launch - then below, we can see the Return to classic SharePoint option.

Return to classic SharePoint

0

The buttons and the ribbon you are referring to are only available on classic pages and lists with classic view.

The page in your screenshot is what the site pages look like today, often referred to as modern pages.
There is no way to display these pages in classic view, you must create a new page that is based on the old publishing framework.

To do that you will may need to activate some features to get the old Pages library back:

Site Collection Feature
This feature is called "SharePoint Server Publishing Infrastructure" and can be found in "Site Collection Features" in Site Settings.

enter image description here

Site Settings -> Site Features

Site Feature
This feature is called "SharePoint Server Publishing" and can be found in "Site Features"

enter image description here


After activating these two features, in the mentioned order, you will find a library called "Pages" under Site Contents:

enter image description here

This is where you can create classic pages and will get the ribbon you are seeking.

enter image description here


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.