I can't open my site with SharePoint Designer 2010.

I get the well known message:

The Web server at "http://tfs" does not appear to have Microsoft SharePoint Foundation installed.

I've spent a good deal of time researching and troubleshooting already and have checked the following:

  • Enable Client Integration is set to Yes for the web application
  • All checkboxes are checked under the site collection's SharePoint Designer Settings
  • Connecting to the Central Administration website from SD works no problem
  • I can browse the site in the SD Open Site window, but when I actually click open, I get the error
  • Logged in and tried as the SharePoint service account, the domain admin account, my account which is an admin, and the site collection admin account
  • Creating a new site collection in the same web application and trying to connect to it yields the same error
  • Compared all the site settings in IIS Manager between the Central Admin site and the web application running on port 80

How can I get this basic SharePoint functionality working (not that anything in SharePoint is basic from an administrative sense...)?

  • Have you tried using the fqdn? http://tfs[.domain.tld]
    – JudasIscariot1651
    Commented Jan 26, 2012 at 23:28
  • Did this ever get resolved? We have the same issue and have tried all of the above suggested steps and the ones in the ms link.
    – user8880
    Commented Jun 15, 2012 at 2:27
  • SharePoint Designer is really screwed up in the way it connects to SharePoint (it uses WebDav). WebDav doesn't operate correctly unless there is a top level site collection. I created a top level site collection and then was able to connect to my sub-site.
    – Jeff
    Commented Aug 21, 2012 at 1:37

1 Answer 1


There is a KB Article available on Microsoft's site. It looks like you have not completed all steps in resolution that it suggests.


  • This did not fix the problem. Is there other suggestions?
    – user14042
    Commented Jan 10, 2013 at 16:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.