I have a backup of a content db restored to Sql server as WSS_Content_Live

I have a brand new SP installation setup with AutoInstaller, so we have a port 80 web site called Portal Home.

I have detatched and deleted Portal Home's content db. I have now added a new content db with the name Wss_Content_Live.

CA reports 0 site collections (there's no top-level site collection) and its confirmed when I browse there's a 404 and I can create a new top-level site collection.

I did this last week and it worked ok, the top site was there restored as expected. It is a publishing site if that matters.

Any ideas? I have tried a couple of times with the same net effect.

It has restored since I can browse its two child site collections. Weird?

Is there a more assured way of doing the restore i could try?


I just tried again with a restore from powersheell using Mount-SPContentDatabase

again it has reported 0 site collections

  • Did you detach the old Content DB before attaching the new one?
    – Dave Wise
    Jan 26, 2012 at 15:24
  • yes and deleted it. you mean from content db manager from CA?
    – BobTodd
    Jan 26, 2012 at 15:28
  • Deleting from the CA is fine, but I've never had good results attaching from there. I always use the admin shell to attach content databases.
    – Dave Wise
    Jan 26, 2012 at 15:31
  • tried with PS, same result
    – BobTodd
    Jan 26, 2012 at 15:58

1 Answer 1


Apparently its the way you restore the database in SQL Server

Dont create the database first then restore it.

Instead right click the server and restore a database, and add a name for the db...it will create it.

TBH that beggars belief!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.