I have some struggle viewing lists with a Group By.

The list contains documents that belong to a certain event. Therefore, we added a lookup field which points to the date + start time from the events. It also adds the event Title using the Add columns to the following fields option. We created a view that is grouping the documents by this event Start Time. It displays the date only though.

This is working fine, but as soon as we exceed the 30 items limit, the group is cut off. This is normal.

Now here's the problem: when I click the group name, it should show a filtered view with all documents that belong to that date. However, it doesn't show any document at all.

I found that this might have to do with the way SharePoint handles the date format. When I click the filter button, I see that it has filtered on date only. When I tick another date, it does show that date. But this time, it shows a different date format on top of the view! See image below.

View with two different date formats

Our SharePoint is set up for The Netherlands. Our date format is day-month-year.

What is going wrong? Am I doing something wrong?

Any help is greatly appreciated. Thanks in advance!

  • It seems that Microsoft has fixed this issue. Groups are working fine now.
    – matsn0w
    Sep 21, 2021 at 11:47

1 Answer 1


I seems have the same issue as you. Please check the steps below if you operate as me:

Per my test, I click the group by name 3/11/2020. enter image description here

Then I click See all in the Filter pane, and select other date options to filter, in the view, it only display the file for 3/3/2020, and the group by name with the wrong format for 3/3/2020.

enter image description here

If the repro steps is same as you, it might the modern filter issue by default. I suggest you filter with other date options when you exit the group by view.

  • I reproduced your steps and got exactly the same result. What do you mean with your last sentence? I don't get it.
    – matsn0w
    Mar 31, 2020 at 15:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.