We have a SharePoint 2013 workflow inside SharePoint designer 2013, as follow:- enter image description here

but when the user create or update a list item and the workflow got triggered, the workflow will stuck on the "started" status and will raise this error:-

enter image description here

HTTP Forbidden to https://***.sharepoint.com/Functions/Human%20Resources/_api/web/lists(guid'ce9839f2-f12c-48f4-a548-f53c18ab5d5d')/Items(4888)

although the user has contribute permission on the list , so the user should be able to call the list api through https://***.sharepoint.com/Functions/Human%20Resources/_api/web/lists(guid'ce9839f2-f12c-48f4-a548-f53c18ab5d5d')/Items(4888).. so not sure why the workflow is mentioning access denied on a list which the user have contribute on? is it an issue with SharePoint online + workflow 2013?

Any advice please?

3 Answers 3


Please give us more information on what the workflow is doing. Offer the workflow steps.

Republish the workflow and compare the results.

To narrow down the issue:

please create a new workflow with just log to history action, check whether the issue exists.

Try to start the workflow with other user, compare the results.

  • the workflow is checking the current values and update some fields + it accessing other lists to retrieve date... but the main issue is that it is showing access denied issue on a list which everyone has contribute on it !!
    – John John
    Mar 19, 2020 at 11:38

You may try running the workflow with elevated permission by using the App step action which is available in SharePoint 2013 workflow template.

The App step action will not be available by default, in order to get this action available, we need to activate the Workflows can use app permissions site feature.

Navigate to Site settings->Manage site features - > Activate the Workflows can use app permissions.

For details steps, you may refer the below URL :

SharePoint 2013 workflow with elevated permissions – App Step

  • but i am trying to have it working without using the elevated permission by using the App step
    – John John
    Mar 18, 2020 at 19:06
  • Then try adding just the impersonation action step at the beginning of the workflow,then all following action will be executed by that higher preveilage account configure in the impersonation action.
    – SP 2022
    Mar 18, 2020 at 19:18
  • this will break the workflow logic in our case, as certain workflow action will be accessing certain lists, which only authorized users can do ..i am already aware of v and impersonation but this will noy work for us for the reasons i mentioned. thanks
    – John John
    Mar 18, 2020 at 20:09

Found this blog entry which had the solution for me: https://blog.houratious.com/2014/06/sharepoint-2013-workflow-server-was.html

The issue was resolved for me by configuring the Security Token Service Application Pool to have "Load User Profile" set to true in the app pool Advanced Settings.

This resolved the issue where the authentication wasn't working to the REST API from the workflow service.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.