0

I have deployed sharepoint 2010 prod backup on newly configured dev sharepoint 2010 machine, and also configured infopath form services in Central admin. but when I am trying to use Customize Form option in ribbon ( with infopath) I am getting given below error


Message from webpage

Microsoft InfoPath 2010 is required to use this feature.

OK

0

Apart from the infopath form service configuration in SharePoint application server, we need to install the infopath client in your local machine either through adding additional add in from the already installed office product or we can install it from Microsoft site - https://www.microsoft.com/en-us/download/details.aspx?id=48734

Note :

  • In order to customize the SharePoint list form we must use the Internet Explorer, in chrome it doesn't work and also you can open it from the ribbon or from the list setting page (open form).

  • If you have already installed the infopath 2010, and still not able to open, then verify your Internet Explorer settings :

    Enable option "Run ActiveX Controls and Plugins" and "Script ActiveX Controls Marked Safe for Scripting" in the IE.Also, try to add the site in safe zone in the IE.

  • Sometimes, by just repairing the office 365 products, this issue gets fixed.

0

Open the site through IE 32 bit. On opening it, made sure the Control Panel ->Admin Tools->Services->Web Client is started and the properties is set to ‘automatic’ instead of manual.

Enable Sharepoint OpenDocuments Class add-on and sharepointopenxmldocuments add-on in IE.

If the issue still exists, Repair Microsoft Office.

Control Panel->Programs & Feautres->MS Office(change) and then choose repair.

Restart the machine.

Refer to the following article troubleshoot the issue:

http://swethasankaran.com/2013/02/25/sharepoint-designer-and-infopath-issues-opening-from-browser/

  • Hi Lisa thank you for quick reply, in my case MS Office is not installed on client machine. – SPDev Mar 18 at 14:48
  • If your issue is solved, please remember to mark the helpful post as an answer. Thanks for your understanding. – Lisa Chen MSFT Mar 25 at 2:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.