2

I met one issue that in some of my site collections (Team site (no Office 365 group)), the folders/files in my created Document Library/List are mixed together like: enter image description here enter image description here

I tried to search and found the similar issue , but I can make sure that the "New Folder" command is available for my Document Library/List. I tried to edited the view to set to first sort with column Type (Icon link to document) but still helpless.

The system Document Library (Documents) have no such issue, but the manually created Library/List have this issue.

Any ideas will be helpful. Thanks very much. Are there any settings for site collection/List/Library may impact the sort result?

BTW, I used the SharePoint client object model (CSOM) to create the List/Library, so if it maybe an bug of CSOM? The list/library created manually have no such issue. If there are an known issue in CSOM on this part?

Thanks -Justin

0

You can try changing the default sort order on your view to "Title" and "Name". Since folders don't have a Title, they will always appear at the top.

This won't help if someone decides to sort by another field however.

| improve this answer | |
  • Thanks. I have ever tried but it does not work. From the screenshots you can see that in the List type, the folder has 'Title' and in the Library the folder has 'Name'. I doubt if there are any settings in site collection which may impact the sort result but cannot find anything. – Justin Shi Mar 2 at 0:52
0

Modify view, in sort section, there is an option: Sort only by specified criteria (folders may not appear before items), Make sure you uncheck this option.

enter image description here

| improve this answer | |
  • Hi @Lisa, thanks for your reply. Yes, it's un-check, I have double confirmed. Also, the "New Folder" command is available. – Justin Shi Mar 2 at 9:08
  • BTW, I used the SharePoint client object model (CSOM) to create the List/Library, so if it maybe an bug of CSOM? The list/library created manually have no such issue. – Justin Shi Mar 2 at 9:14
  • Are there any settings which may impact the sort results? – Justin Shi Mar 3 at 3:43
0

It causes by a system built-in field "SortBehavior" in the site collection. Also, I found if items under List have sorting issues, check it's property: SortBehavior.

| improve this answer | |
  • Is there any way to change the sort behavior? I can see it, but its read only in the CSOM – michael Sep 29 at 10:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.