2

I have a requirement to search on a specific library containing approximately 1000 documents. I have created a new page called 'Search' and added Search Bar, Search Results and Search Refiner webparts. I then created a custom Result Source at the site collection level with the following query string: Path:http://cdc/cdc/CorporateDocs {searchTerms}

When I enter a search term a series of refiners appear in the Search Refiners webpart and a Results Count appears at the Bottom of the Search Results webpart but no results are displayed. Instead, the 'Nothing here matches your search' message stays in place.

Clearly the system is finding results, why is it not displaying them?

  • is the path really "http" and not https? – ReTech Feb 26 at 14:49
  • yes, this is being worked on in a ringfenced dev environment with no external access. There was no need to go to the expense of buying an SSL cert. when it moves to production it will be HTTPS – JonS Feb 26 at 14:51
1

OK, it turns out that there is a checkbox in the settings menu of the task pane called 'Disable Ranked Results' if you uncheck that box, your results stop being displayed. D'oh!

| improve this answer | |
0

Due to the Microsoft Documentation you need to do the following:

To return items located in folders in the site that you specify for the path property, you have to add /* to the URL of the specified site; for example, path: "https://contoso.sharepoint.com/Shared Documents/*"

see this doc

a library is for Sharepoint a "Folder" so adding "/*" should help you

| improve this answer | |
  • Nope, this one didn't work. Search results still aren't displaying – JonS Feb 26 at 15:35
0

Make sure that your "Search Box" webpart is properly configured to "Send Results" to your "Search Results" webpart. Perform the following steps:

  • On your custom Search Page, click the Settings menu, and then click Edit Page.
  • In the Web Part, click the Search Box Web Part Menu arrow, and then click Edit Web Part.
  • In the Search Box tool pane, under Properties for Search Box, expand Which search results page should queries be sent to.
  • To use the settings that are defined on the Search Settings page, select the Use this site's Search Settings check box.
  • To override the settings that are defined on the Search Settings page, clear the Use this site's Search Settings check box.
  • To show search results in a Web Part on the page, in the section Send queries to other Web Parts on this page, select a Web Part.

For more details on configuring the Search Box web part, seehttps://docs.microsoft.com/en-us/sharepoint/search-box-web-part#change-where-search-results-are-displayed

| improve this answer | |
  • I've double checked those settings. No joy. seach results still don't display – JonS Feb 26 at 16:10
0

Check the crawl logs in the search service application (if you have access) at that path to make sure the items are in the index. You can enter http://cdc/cdc/CorporateDocs/* in the URL field and look for successful crawls.

If they are, when you setup the result source query, make sure you are seeing results in the test part of the query builder before saving it.

Also, you should be able to query for path: http://cdc/cdc/CorporateDocs similar to how ReTech says but on the out of the box search results page. That should help rule out misconfiguration of your web parts.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.