1

We recently had to make a change on our 2013 SharePoint Server to disable TLS 1.0 and enable TLS 1.1 and TLS 1.2. On our WF Server we had Service Bus 1.0 and we have upgraded to Service Bus 1.1 with TLS 1.1 and TLS 1.2 Support. We have WF CU5 installed on WF Server. All WF and Service Bus services are running on the Workflow Server. We have rebooted the WF Server. We are still receiving errors on 2013 WF when clicking on a list and then clicking on the ellipsis then clicking the option workflow. Do you know the reason? We have not rebooted the SP 2013 Server yet?

This is what I see when try to publish a 2013 Workflow. SharePoint Designer 2013 Workflow Error

I ran the Register-SPWorkflowService command and I got the error below. Register-SPWorkflowService

4
  • What is the error? Show pls.
    – Raf
    Feb 22, 2020 at 17:14
  • I had an issue with that scenario (updating existing WFM to tls 1.2 only) and never made it work. From what I could see to make it work, you need to build up new workflow farm and do an DR restore of the Database data. But as the WFM is so unreliable we just ditched it and moved back Workflow 2010. The DR scenario with WFM is just a nightmare. Feb 24, 2020 at 11:33
  • I saw this in the logs. Application error when access /_layouts/15/Workflow.aspx, Error=The client and server cannot communicate, because they do not possess a common algorithm at System.Net.SSPIWrapper.AcquireCredentialsHandle(SSPIInterface SecModule, String package, CredentialUse intent, SecureCredential scc) at System.Net.Security.SecureChannel.AcquireCredentialsHandle(CredentialUse credUsage, SecureCredential& secureCredential)
    – Kevin
    Feb 24, 2020 at 14:49
  • Getting Error Message for Exception System.Web.HttpUnhandledException (0x80004005): Exception of type 'System.Web.HttpUnhandledException' was thrown. ---> Microsoft.Workflow.Client.WorkflowCommunicationException: The underlying connection was closed: An unexpected error occurred on a receive. Client ActivityId : e799389f-4df8-20e8-734b-e692af823aa8. ---> System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a receive. ---> System.ComponentModel.Win32Exception: The client and server cannot communicate, because they do not possess a common algorithm
    – Kevin
    Feb 24, 2020 at 14:50

1 Answer 1

0

You can follow the article to make sure you have upgrade Service Bus for Windows Server to use TLS 1.1 and TLS 1.2 correctly. Windows Service Bus 1.1 with TLS 1.2 Support

If the issue exists, you can provide the error message or screenshots when you click Workflow in a list.

3
  • When I upgraded the service bus. I ran the Stop-SBFarm, Remove-SBHost, and finally added the SB host back. Do I need to run the Register-SPWorkflowService -SPSite site_name -WorkflowHostUri workflow.contoso.com:12290 command again? Will it mess things up if I run it again?
    – Kevin
    Feb 25, 2020 at 1:39
  • Yes, I recommend you run the Register-SPWorkflow Service to check if the issue exist. Note for workflowhosturi parameter select the proper Port if using http then 12291 or for https use 12290. Feb 25, 2020 at 1:48
  • I did run Register-SPWorkflowService and it displayed an error. In Central Administration under Workflow Service Status it does still say Workflow is Connected. Do you have any suggestions?
    – Kevin
    Feb 25, 2020 at 22:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.